Как найти день недели по дате в Microsoft Excel

Хотите преобразовать любую дату в формате соответствующего ей дня недели для своей таблицы Excel? В таком случае, у вас есть достаточное количество формул и приемов, помогающих это реализовать. Сейчас мы продемонстрируем наглядно, как эффективно найти день недели по дате.

Для определения этого вы можете воспользоваться тремя основными методами. Самый первый позволяет представить данные в виде числа. В этом случае, например, отсчет будет вестись с воскресенья, которому соответствует номер 1, а понедельнику — номер 2 и т.д.

Второй метод выводит название в виде, например, «понедельник», «вторник» и т.п. Третий переформатирует полное название в сокращенный вид.

Найти день недели по дате в числовом виде

Внимание, в этом виде расчет будет начинаться с воскресенья, обозначаемого цифрой «1»!

  1. Откройте таблицу с существующими данными.
  2. Выберите ячейку, где необходимо вывести день недели.
  3. В ней введите формулу =ДЕНЬНЕД(A1), в которой А1 замените на ту ячейку, где находится дата.
  4. Нажмите клавишу ввода на клавиатуре.

Для вывода остальных значений, просто скопируйте формулу и вставьте в нужное место. Готово!

Вывод даты в виде числа дня недели
Числовой вид даты

Поиск дня недели в формате названия

  1. В электронной таблице Excel отметьте ту ячейку, в какой необходимо отобразить имя.
  2. Напишите формулу =ТЕКСТ(A1;«dddd»), где, как и в первом случае, А1 замените на ячейку с датой.
  3. Подтвердите изменение нажатием клавиши Enter.

Скопируйте и вставьте формулу для других дат. Готово! Если вам нужно показать имя в сокращенном виде, например «пн» или «вс», примените формулу в формате =ТЕКСТ(A1;«ddd»).

Название дня недели вместо даты
Вывод названия дня недели

Изменение дат в дни недели

Исходя из того, каким способом вам нравится оформлять таблицы, вы легко сможете изменить имеющиеся значения, не используя для этого отдельный столбец. С этой целью:

  • откройте существующую таблицу Excel;
  • выделите все ячейки, содержащие даты;
  • в контекстном меню правой кнопки мыши выберите пункт «Формат ячеек»;
  • слева кликните на «все форматы»;
  • в правой части окна для поля «Тип» укажите необходимый формат вида, например, dddd;
  • нажмите на кнопку «ОК». Готово.
Формат даты в ячейке
Тип формата

Все выделенные вами на начальном этапе даты будут преобразованы в названия. Осталось применить выравнивание по нужному образцу.

Автоматическое преобразование даты в день недели
Преобразованная дата в день недели

Заключение

Как можете убедиться, найти день недели по дате в электронной таблице Microsoft Excel, не составляет труда. Это знание пригодится вам в повседневной работе. Спасибо за внимание!

Оставьте комментарий